cURL / Mailing Lists / curl-library / Single Mail


RE: Portability

From: Patrick Monnerat <>
Date: Thu, 12 Jun 2008 14:35:42 +0200

Daniel Stenberg wrote:
> We write libcurl to build and work with lots of third party tools,
and we
> want it to remain functional and buildable with these and later
versions (i.e
> older may work but is not what we work hard to maintain):

> qsossl ?

There is no version information about OS400 SSL (qsossl) itself. Only
the OS400 version can be refered to.
Currently, libcurl (and thus qsossl support) can be compiled for OS400
V5R2M0 or later, (I tested V5R2M0, V5R3M0 and V5R4M0). The latest
(untested) version is V6R1M0. IBM does not support V5R2M0 and earlier

FYI: an OS400 version can generate objects in compatibility mode for the
current version and the 2 preceding versions. V5R4M0 is installed on our
machine. That's why I'm able to test from V5R2M0. When we'll migrate to
V6R1M0, I'll only be able to test compatibility wth V5R3M0 and up. At
any time, IBM only supports the 3 latest versions.

I'll be glad if some other OS400 user (perhaps with another
configuration) performs compatibility tests and reports them to this

Received on 2008-06-12