Re: [PATCH] 64 bit "skew" detector
Date: Sun, 1 Jun 2008 00:33:43 +0200 (CEST)
On Fri, 30 May 2008, Yang Tse wrote:
>> How about just build.h ? We're already using our own subdir so it would be
>> curl/build.h anyway...
> For the very same reason that Dan mentions I prefer a 'curl' prefixed name
> that makes the file name unique from other software's potential build.h
I'm not sure I buy that, as then we can possibly collide anything. I think
config.h explicitly is a bad idea just because it is so very widely used
exactly as the output from configure.
But I don't feel very strongly about either way so I'm fine with a curl prefix
on this header.
> I was also thinking of curldefs.h but I have the feeling that it 'invites'
> to make changes to it.
I think a very large and instructive comment in the header that explains the
purpose of the file should make people aware of that changing that file isn't
(normally) a good idea.
> How about curlrules.h with an intentional double meaning ?
Hah, it certainly works for me! I wouldn't mind having to type "curlrules" a
couple of times in my everyday life ;-)
-- / daniel.haxx.seReceived on 2008-06-01