CURL_SIZEOF_CURL_OFF_T vs SIZEOF_CURL_OFF_T
Date: Sun, 10 Aug 2008 15:38:24 +0200
The 64-bit curl_off_t patch has introduced symbol
CURL_SIZEOF_CURL_OFF_T which is used both internally and externally,
from this last one the need of the 'CURL_' prefix.
Internally we were using SIZEOF_CURL_OFF_T, and up to now setup.h
defines this based on CURL_SIZEOF_CURL_OFF_T.
But I think that having and using both symbols should be 'fixed' to
only use CURL_SIZEOF_CURL_OFF_T and avoid the confusion of having two
symbols for actually the same purpose.
Ok to proceed with this ?
-- -=[Yang]=-Received on 2008-08-10