cURL / Mailing Lists / curl-library / Single Mail

curl-library

Re: nearly all tests failing for me with curl 7.29.0 on Mac OS 10.8

From: Paul Heckbert <ph_at_cs.cmu.edu>
Date: Fri, 1 Mar 2013 18:39:19 -0500

I now see that I had two independent problems.

The first problem, that my application was gobbling memory and hanging, I was able to track down by rebuilding libcurl with "./configure --enable-debug", and gdb. My code, which worked fine as a 32 bit application, was passing int arguments to curl_formadd( CURLFORM_BUFFERLENGTH ...) where longs were called for. That worked fine in a 32 bit app, but on a 64 bit app (where int=4 bytes and long=8) it resulted in a bufferlength > 4GB. So that was my bug, and easy to fix.

The second problem, that "make test" initially reported "OK: 0%", has now disappeared for reasons I do not understand.
Now I get
TESTDONE: 608 tests out of 610 reported OK: 99%
TESTFAIL: These test cases failed: 591 592
Which is good enough for me. Between then and now I've done "make distclean; ./configure --prefix=`pwd`/build; make; make install; make test" and the like, plus the "make check" command Dan Fandrich suggested. Little more than that. I don't have an explanation for why the tests went from (roughly) all failing to all passing. But my app is working, so I'm happy. PS: I'm not running a firewall.

> Date: Thu, 28 Feb 2013 16:57:49 -0700
> From: Nick Zitzmann <nick_at_chronosnet.com>
>
> Paul, are you using a firewall by any chance?

-------------------------------------------------------------------
List admin: http://cool.haxx.se/list/listinfo/curl-library
Etiquette: http://curl.haxx.se/mail/etiquette.html
Received on 2013-03-02