Haxx ad

curl's project page on


cURL > Mailing List > Monthly Index > Single Mail

curl-tracker mailing list Archives

[ curl-Bugs-1701360 ] Solaris 10 link failed due to wrong order of -l/-L switches

From: <>
Date: Mon, 16 Apr 2007 02:21:56 -0700

Bugs item #1701360, was opened at 2007-04-16 10:57
Message generated for change (Comment added) made by eku
You can respond by visiting:

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: compile or build problem
Group: portability problem
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Erik Kunze (eku)
Assigned to: Daniel Stenberg (bagder)
Summary: Solaris 10 link failed due to wrong order of -l/-L switches

Initial Comment:
We try to compile Curl 7.16.2 on Solaris 10. The directories given to 'configure --with-ssl=xyz' are put after the libraries for the linking process.

/bin/bash ../libtool --tag=CC --mode=link /tools/Solaris/WS/bin/cc -version-info 4:0:0 -lssl -lcrypto -lsocket -lnsl -lz -R /usr/sfw/lib -L/tools/Solaris/openssl/lib -L/tools/Solaris/SunOS/usr/lib -o -rpath /opt/SMAW/SMAWcurl/lib file.lo timeval.lo base64.lo hostip.lo progress.lo formdata.lo cookie.lo http.lo sendf.lo ftp.lo url.lo dict.lo if2ip.lo speedcheck.lo ldap.lo ssluse.lo version.lo getenv.lo escape.lo mprintf.lo telnet.lo netrc.lo getinfo.lo transfer.lo strequal.lo easy.lo security.lo krb4.lo memdebug.lo http_chunks.lo strtok.lo connect.lo llist.lo hash.lo multi.lo content_encoding.lo share.lo http_digest.lo md5.lo http_negotiate.lo http_ntlm.lo inet_pton.lo strtoofft.lo strerror.lo hostares.lo hostasyn.lo hostip4.lo hostip6.lo hostsyn.lo hostthre.lo inet_ntop.lo parsedate.lo select.lo gtls.lo sslgen.lo tftp.lo splay.lo strdup.lo socks.lo ssh.lo nss.lo
/tools/Solaris/SunOS/usr/ccs/bin/ld -G -h -o .libs/ .libs/file.o .libs/timeval.o .libs/base64.o .libs/hostip.o .libs/progress.o .libs/formdata.o .libs/cookie.o .libs/http.o .libs/sendf.o .libs/ftp.o .libs/url.o .libs/dict.o .libs/if2ip.o .libs/speedcheck.o .libs/ldap.o .libs/ssluse.o .libs/version.o .libs/getenv.o .libs/escape.o .libs/mprintf.o .libs/telnet.o .libs/netrc.o .libs/getinfo.o .libs/transfer.o .libs/strequal.o .libs/easy.o .libs/security.o .libs/krb4.o .libs/memdebug.o .libs/http_chunks.o .libs/strtok.o .libs/connect.o .libs/llist.o .libs/hash.o .libs/multi.o .libs/content_encoding.o .libs/share.o .libs/http_digest.o .libs/md5.o .libs/http_negotiate.o .libs/http_ntlm.o .libs/inet_pton.o .libs/strtoofft.o .libs/strerror.o .libs/hostares.o .libs/hostasyn.o .libs/hostip4.o .libs/hostip6.o .libs/hostsyn.o .libs/hostthre.o .libs/inet_ntop.o .libs/parsedate.o .libs/select.o .libs/gtls.o .libs/sslgen.o .libs/tftp.o .libs/splay.o .libs/strdu!
 p.o .libs/socks.o .libs/ssh.o .libs/nss.o -R/usr/sfw/lib -lssl -lcrypto -lsocket -lnsl -lz -L/tools/Solaris/openssl/lib -L/tools/Solaris/SunOS/usr/lib -lc
ld: fatal: library -lssl: not found
ld: fatal: library -lcrypto: not found

Solaris Linker requires -L before -l flags.

This worked with Curl 7.10.0. I noticed, tha Curl now
uses automake 1.10 and lib/ line 'libcurl_la_LDFLAGS' has changed. These changes break the Solaris build.


>Comment By: Erik Kunze (eku)
Date: 2007-04-16 11:21

Logged In: YES
Originator: YES

Some remarks concerning sunfreeware version. They build with GCC and not
Sun's Studio 11 compiler.


Comment By: Erik Kunze (eku)
Date: 2007-04-16 11:15

Logged In: YES
Originator: YES

We need to build our own Solaris 10 package because:
1) both 32 and 64 bit builds in one package
2) custom configure flags
3) different installation location

The reason why our build fails, is we use a toolset to compile and build.
The native header files and libraries that are installed on the build host
are note used. That is why we specify all locations via configure switches
(some kind of cross compiling).

That worked fine with 7.16.0, where the order of -l/-L options was

The build from
works because
buildconf is called and automake 1.9.6 is used for this. This is known to

The source archive you distibute has been build with automake 1.10 and the
result is
 not working because of libs/!

The distributed source archive must work out of the box. We do not have
installed autmake/autoconf.


Comment By: Daniel Stenberg (bagder)
Date: 2007-04-16 11:06

Logged In: YES
Originator: NO

First, wouldn't this be the same on all Solaris versions?

Then, clearly (
built their packages fine with OpenSSL...

And last, the current autobuilds build fine on Solaris 10 with OpenSSL
( even though the
link will die within a few days)

Can you figure out what makes your case different from these others?


You can respond by visiting:
Received on 2007-04-16

These mail archives are generated by hypermail.

donate! Page updated November 12, 2010.
web site info

File upload with ASP.NET