cURL / Mailing Lists / curl-users / Single Mail


Compiling Curl with SSL support issues.

From: Dan Pellicer <>
Date: Tue, 10 Mar 2009 16:11:51 -0700

I've been having some issues getting Curl to compile on a system with
SSL support... I had not built the offending system so I decided to
build up a test machine so I would have a machine in a non production
env to test on..

it is running Suse 9.2

I installed OpenSSL 0.9.8j... with the vanilla ./config , make,
make test, make install method .. as per the OpenSSL install docs,
this installs it to /usr/local/ssl and make test does not indicate
any issues.

on this machine when I just run ./configure it does not include SSL support.

configure: Configured to build curl/libcurl:

  curl version: 7.19.4
  Host setup: i686-pc-linux-gnu
  Install prefix: /usr/local
  Compiler: gcc
  SSL support: no (--with-ssl / --with-gnutls)
  SSH support: no (--with-libssh2)
  zlib support: enabled
  krb4 support: no (--with-krb4*)
  GSSAPI support: no (--with-gssapi)
  SPNEGO support: no (--with-spnego)
  c-ares support: no (--enable-ares)
  ipv6 support: enabled
  IDN support: no (--with-libidn)
  Build libcurl: Shared=yes, Static=yes
  Built-in manual: enabled
  Verbose errors: enabled (--disable-verbose)
  SSPI support: no (--enable-sspi)
  ca cert bundle: no
  ca cert path: no
  LDAP support: enabled (OpenLDAP)
  LDAPS support: no (--enable-ldaps)

If I specify the SSL dir with ./configure --with-ssl=/usr/local/ssl
     configure bonks stating the following.

./configure: line 23438: /usr/local/ssl: is a directory
checking for CRYPTO_lock in -lcrypto... no
checking for CRYPTO_add_lock in -lcrypto... yes
checking for SSL_connect in -lssl... no
checking for ssl with RSAglue/rsaref libs in use... checking for
SSL_connect in -lssl... (cached) no
configure: error: OpenSSL libs and/or directories were not found where

Am i doing something wrong here?? Thanks in advance!
List admin:
Received on 2009-03-11