cURL / Mailing Lists / curl-library / Single Mail


Re: rename config.h to curl_config.h?

From: Daniel Stenberg <>
Date: Mon, 13 Jul 2009 00:31:22 +0200 (CEST)

On Sun, 12 Jul 2009, Guenter wrote:

> although I've not yet run into a prob with config.h, I think sooner or later
> this will happen because still many other projects have a config.h, and then
> its only a matter of the include paths which config.h will be found first -
> therefore I would like to suggest that we rename it to curl_config.h to make
> sure we really read back _our_ defines we have checked for ...
> thoughts?

Fair enough. I can't see any harm in that and it might avoid future problems.
And it also makes it easier when you have multiple files loaded in your text
editor etc. I'm all for it.

Received on 2009-07-13